Hyperion.ng - wrong pixel format?

  • I'm having an issue getting my setup working. I've tried several different grabbers (UTVF with the no-change workaround) with both OpenELEC and LibreELEC, and I've gotten furthest with Libre. The current error I'm getting is:


    "V4L2GRABBER ERROR: Only pixel formats UYVY, YUYV, and RGB32 are supported ERROR"


    Honestly this is an improvement over OpenELEC because I struggled to get it to even recognize my grabber. Is there some way I can change the pixel format coming from my grabber?


    Any advice would be greatly appreciated!


    HyperCON log:


    JSON File:

  • I have both versions downloaded on my computer, and I stepped back into this project after rage-quitting quite a while ago so I’m actually not surprised that I left off on the wrong version. I’ll start over and see where it gets me. Thanks!

  • After you install the software on the pi open up a ssh connection and run “lsusb” with out quotations. Make sure the usb grabber is not connected then after that command plug in your usb grabber and re-run the command to see if it shows up if it doesn’t then it means your devices is not being recognized by the pi.

  • With hyperion (classic), v4l2-ctl -v pixelformat = YUYV must be set.


    greetings pclin

  • Search for the hyperion.service file, and add befor ExecStart=
    ExecStartPre=/usr/bin/v4l2-ctl -v pixelformat = YUYV


    This is how it looks for me on the Dreambox TWO. the RPI should look similar.
    Use a linux compliant editor geany, notepad++, set end of line to LF (Unix).



    greetings pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.12 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited 5 times, last by pclin ().


  • Hi pclin,


    I tried your advice but I still get the
    VIDIOC_S_STD ERROR 25, Inappropriate ioctl for device



    When I use Putty to manually send:
    v4l2-ctl -v pixelformat = YUYV


    And then afterwards send the command:


    hyperion-v4l2 --device /dev/video0 --input 0 --width -1 --height -1 --crop-left 0 --crop-right 0 --crop-top 0 --crop-bottom 0 --size-decimator 1 --frame-decimator 2 --red-threshold 0.0 --green-threshold 0.0 --blue-threshold 0.0 --screenshot


    I can then afterwards see the grabbed image in HyperCon, so I know it works, but still Hyperion fails to work.


    Is it maybe possible to send me your hyperion.config.json and hyperion.service file?


    Or are there other things I'm missing.


    Thank you again for the quick replies :)

  • My hyperion.config.js and hyperion.service files are created by me for the Dreambox ONE / TWO, as is my version of hyperion (classic), which you cannot simply use. I don't use an RPI either, but ESP8266 with WLED. My config.json also had additional entries. The service file also contains additional entries for my system.


    Here I posted the part for the grabber.
    The part can be taken over 1:1.


    greetings pclin

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!