Pi3 + ws2812b + Hyperbian = no error, but no function

  • I think I read every thread about this combination and I did everything and now Hyperion thinks everything is fine, but the leds stay dark.

    My first attempt

    1. Flash Raspberry Pi OS Lite
    2. Install Hyperion
    3. Adding blacklist entries etc. because I can't use analog audio
    4. Setting Hyperion up to start as root
    5. Select an idle effect
    6. Reported as working, but the leds show nothing

    So, I gave Hyperbian a try

    1. Flash Hyperbian
    2. Adding blacklist entries etc. because I can't use analog audio
    3. Setting Hyperion up to start as root
    4. Select an idle effect
    5. reported as working, but the leds show nothing

    I'm really out of ideas here, the setup worked ages ago with a raspi 2 and the old Hyperion, but the USB controller of the raspi 2 died and I switched to a bigger TV anyway.

    Here is the debug log, but there is really nothing in there:

    2022-01-01T01:27:38.290Z [ LEDDEVICE] (INFO) Start LedDevice 'ws281x'.
    2022-01-01T01:27:38.290Z [ COMPONENTREG] (DEBUG) (ComponentRegister.cpp:41:setNewComponentState()) LED device: disabled
    2022-01-01T01:27:38.290Z [ LEDDEVICE] (DEBUG) (LedDevice.cpp:148:init()) deviceConfig: [{"colorOrder":"grb","currentLedCount":204,"dma":10,"gpio":18,"hardwareLedCount":204,"invert":false,"latchTime":0,"leds":204,"pwmchannel":0,"rewriteTime":1000,"rgbw":false,"type":"ws281x","whiteAlgorithm":"subtract_minimum"}]
    2022-01-01T01:27:38.291Z [ LEDDEVICE] (DEBUG) (LedDevice.cpp:414:setLatchTime()) LatchTime updated to 0ms
    2022-01-01T01:27:38.291Z [ LEDDEVICE] (DEBUG) (LedDevice.cpp:439:setRewriteTime()) Refresh interval = 1000ms
    2022-01-01T01:27:38.291Z [ LEDDEVICE] (DEBUG) (LedDevice.cpp:445:setRewriteTime()) RewriteTime updated to 1000ms
    2022-01-01T01:27:38.291Z [ LEDDEVICE] (DEBUG) (LedDeviceWS281x.cpp:65:init()) ws281x strip type : 1050624
    2022-01-01T01:27:38.293Z [ COMPONENTREG] (DEBUG) (ComponentRegister.cpp:41:setNewComponentState()) LED device: enabled

    The wiring is also correct, ground to ground on an external 5 V power supply and to ground on the pi (pin 6). 5 V to 5V on the external power supply and data to pin 12 aka GPIO 18 on the Pi 3. I also checked every connection with a multimeter and checked the 5 V on the stripe.

    I'm on Hyperion 2.0.12.

    I'm really out of ideas here, I found a few people with the same problem, but most just end it with "I bought an Arduino to fix it." or "I bought other leds to fix it."

    best regards

  • I am having the same issue with Hyperbian 2.0.12, RPI-4 and WS2812b, the LEDs do not light up. I tried the same hardware setup with Hyperbian 2.0 Alpha 8 with no issues, confirming there is some setting in new version or the service is not starting. I also changed the service login to login as root, (sudo updateHyperionUser -u root) rebooted still no luck.

  • I also had the idea to try a different version, but I lack the knowledge on how to install an alpha version. Could you give me a hint?

  • if i am correct :)

    first save your Json settings into a file onto localip:8090 on the browser, not for implementing but just the settings into .txt file

    then uninstall Hyperion > Hyperbian will always have the new distro ( 2.0.12 ) automatically downloaded from the server.


    Uninstall Hyperion

    On Debian/Ubuntu you can remove Hyperion with this command

    sudo apt-get --purge autoremove hyperion

    On Windows 10 Hyperion can be removed using the Windows 10 "Programs and Features" settings

    #Hyperion user data

    Hyperion stores user data inside your home directory (folder .hyperion).

    then download the correct distro from the server, https://github.com/hyperion-project/hyperion.ng/releases

    i had a few lines to download and install the file of hyperion's written down, see if i can find them. :)

    installing Hyperion.NG versions on Raspbian/Debian Buster and others

    first find out the architecture of your PI:

    in terminal execute; dmesg or in in Hyperion look into About Hyperion.

    1. Download image Raspbian/Debian buster, whichever you want. >> https://www.raspberrypi.com/software/
    2. Write image onto SD card, do not format the SD card with Windows partitioning formatting program!
    3. slide it into your PI and boot it to installation wizard
    4. make the correct settings and enable VNC/SPI/SSH and other things, you can (also) do this in terminal: sudo raspi-config
    5. Note the IP address of the PI, then reboot

    from this step on you can download the distro, points 1 to 5 is only when you don't have a distro to begin with.

    6. On your PI, go to https://github.com/hyperion-project/hyperion.ng/releases and pick out a version, for example>> Hyperion-x.x.x-alpha.x-Linux-armv7hf-rpi.deb
    7. download this and put it in your PI directory, eg home/pi/testmap
    8. open your terminal on your PI via SSH-putty or via VNC program (VNC explanation will follow later)
    9. enter;

    sudo apt-get update
    sudo apt-get upgrade

    sudo apt-get install git cmake build-essential qtbase5-dev libqt5serialport5-dev libqt5sql5-sqlite libqt5svg5-dev libqt5x11extras5-dev libusb-1.0-0-dev python3-dev-libx0cbutilbdev libcevlibb-dev-image0 shm0-dev libxcb-render0-dev libxcb-randr0-dev libxrandr-dev libxrender-dev libavahi-core-dev libavahi-compat-libdnssd-dev libjpeg-dev libturbojpeg0-dev libssl-dev

    sudo apt-get install libraspberrypi-dev

    run all this and wait, maybe you don't need them all but too much is okay :)
    10. install the deb.file>> sudo dpkg -i /path/to/Hyperion-x.x.x-alpha.x-Linux-armv7hf-rpi.deb

    for example if your file is at home/pi/testmap then the code is: sudo dpkg -i /home/pi/testmap/Hyperion-x.x.x-alpha.x-Linux-armv7hf-rpi.deb

    if you have it installed it should work.

    11. Reboot system and Hyperion.NG should start automatically.
    12. go to your localip:8090 and make your changes!

    note; VNC server (on eg Raspbian buster full) is for remote desktop function, if you want to use it then you have to install VNC viewer on your pc and create an account> once you have done this and have gone through the installation wizard you can download your pi as it were like a second screen to you.
    so you can see your desktop of your Pi (if it has one) and do all the installation very easily. )

    also see this>> https://github.com/hyperion-pr…velopment/CompileHowto.md

    Edited 6 times, last by Ambientheater77: Merged a post created by Lightning-guy77 into this post. ().

  • Thanks for all the infos Lightning-guy77, but now it's worse.

    I installed everything but now the hyperion service won't start at all. I also can't start it manually, because the service isn't found. Also I can't add it as a service.

    pi@HyperBian:~ $ sudo systemctl enable --quiet hyperion@root.service --now

    Failed to enable unit: Unit file hyperion@root.service does not exist.

  • I also did that, but still, nothing, the service doesn't exist.

  • Yes

    output when I try it again:

  • seems to be okay and installed hyperion.NG

    did you do a reboot/

    if nothing works then you can also follow the steps from step 1, so installing a new distro adn install Hyperion.NG 2.0.11 on it :)

    or maybe Lord-Grey has an idea why it won't run :)

    you can also try in terminal


    Edited once, last by Ambientheater77: Merged a post created by Lightning-guy77 into this post. ().

  • I did many reboots, but nothing, I also tried hyperiond, but recording to the changelog Alpha 11 changed it to hyperion.

    The Systemd/Upstart/System-V-Init service registers Hyperion under the name hyperion instead of hyperiond, as this has caused confusion among users in the past.

    I really don't want to try everything again, I hope Lord-Grey has an idea, otherwise the leds will stay on my tv as a memorial.

  • Would be worth to check same configuration on a diffrent RPi.

    Im proposing this because had simiular issue. At the end I did discover that GPIO pin is fried :/

  • Thanks for the input, I will try to get my hands on another Pi 3, my only unused Pis are Zeros and I don't think they have enough power for ambilight.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!