WLED schaltet ab

  • Hallo zusammen,


    ich habe da ein Problem mit einem Ambilight mit WLED

    Nach dem einschalten läuft das Ambilight jedoch nach paar Minuten ist es wieder aus. Also WLED geht aus.

    Das ist schon eine Zeitlang aber ich komme nicht drauf was los ist.

    Aufgefallen ist es mir seit ich auf Version 14 upgegradet habe.


    Habe die Log mit angefügt. Vielleicht kann jemand helfen?



    Danke ;)



  • Ich vermute das du mit Farben und Effekten keine Probleme hast, das sollten dauerhaft ohne Aussetzer funktionieren.

    Laut log wird WLED ausgeschaltet weil es Probleme mit dem v4l2 Device gibt, No such device


    gruß pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Amp: Pentagon - Lautsprecher ELAC / ARENDAL
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.16-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x ESP32/Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    FeinTech VSP01201 - Grabber Macrosilicon

    LG TV Hyperion webOS & PicCap


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    • Official Post

    Ich habe noch den Timer den ich verwende, bei dir muss der entsprechend angepasst werden, das hatten wir ja schon mal gemacht.

    Dateiname und bei UNIT=


    gruß pclin


    ps.

    wundert mich nur das du den immer noch benötigst...

  • Danke Dir.


    Leider muss ich immer noch per hand einschalten ja.

    Woran es liegt weis ich nicht.


    Beide Systeme laufen mittlerweile mit Hyperion V2.0.14

    Libreelec mit 10.0.3


    Wünsche übrigens noch ein gute neues Jahr. Hoffe gut reingekommen?


    Verstehe ich richtig bei Dateiname und Unit muss ich das "aml" weglassen?


    Habe grade nur wieder das Problem das er den Timer nicht finden kann obwohl ich eigentlich alles am richtigen Ort platziert habe.

    War letztes mal auch so ein Drama.

    hyperion.service ist im Verzeichnis


    Edited once, last by ThoRiWa: Ein Beitrag von ThoRiWa mit diesem Beitrag zusammengefügt. ().

  • Es scheint nicht zu klappen.

    Der Timer ist am richtigen Ort aber es klappt nicht.


    RaspiWohnen:~ # ls -la /storage/system.d/system

    ls: /storage/system.d/system: No such file or directory

    RaspiWohnen:~ #


    Bin die Postings nochmal komplett durchgegangen aber ....



    Was kann an denn machen das man den Timer nicht mehr benötigt?

    Du sagst ja da man den normal nicht benötigt.


    Gruss

    Tomm

  • Das sieht aber nicht so aus das der Timer am richtigen Ort ist.

    Ist der in dem Ordner wo auch der hyperion.service liegt?


    Hier nochmals der Timer der für dich passen sollte, du hast auch einen Fehler bei dem Dateinamen.

    Wenn der systemd-hyperion.timer in dem Ordner liegt in dem auch der hyperion.service ist dann nochmals


    Code
    systemctl daemon-reload
    systemctl disable hyperion.service
    systemctl enable systemd-hyperion.timer


    gruß pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Amp: Pentagon - Lautsprecher ELAC / ARENDAL
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.16-beta.1 (dreamOS)
    Hyperion-ng (Debian bullseye)
    -
    6 x ESP32/Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    FeinTech VSP01201 - Grabber Macrosilicon

    LG TV Hyperion webOS & PicCap


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin ().

  • Also am richtigen Ort ist es.


    Leider aber ohne Erfolg.

    Alles im Ordner system und default.targets.wants


    Code
    RaspiWohnen:~ # systemctl daemon-reload
    RaspiWohnen:~ # systemctl disable hyperion.service
    Removed /storage/.config/system.d/default.target.wants/hyperion.service.
    RaspiWohnen:~ # systemctl enable systemd-hyperion.timer
    Failed to enable unit: Unit file systemd-hyperion.timer does not exist.
    RaspiWohnen:~ # 



    Gruss

    Tomm


    Fehler im Dateinamen... Habe ich das was übersehen?


    gruß Tomm

  • Hi pclin


    Eventuell sieht man hier in der Log einen Fehler warum die LED Hardware nicht einschaltet?


    Bisher hat der Timer ja noch nichts gebracht.

    Anebeiden Systemen die ich habe.


    Du fragtest ja warum ich überhaupt noch einen brauche? Wie war das gemeint?


    • Official Post

    Das WLED Device kann über das Netzwerk nicht richtig angesprochen werden. Operation Cancelled weist auf einen Timeout hin.

    Entweder

    - WLED ist nicht gestartet

    - hat mittlerweile eine andere IP

    - versuche mal Wifi Sleep im WLED Netzwerk Screen zu deaktivieren.


    Zusätzlich könntest Du noch versuchen den Restore State auszuschalten, dann wird das Kommando nicht geschickt.

  • Lord-Grey





    zum einen habe ich ja den Raspi 4 immer an. Da war dann bisher die LED Hardware aus in Hyperion.


    Wenn ich dann WLED einschalte ist die Hardware immer noch aus, muss die dann wieder manuell einschalten.

    Geht nicht automatisch, trotz Timer. Ist aber erst mal ne andere Sache

    Wenn dann WLED aus ist schaltet auch die LED Hardware wieder aus.


    Ich habe ein Vermutung. pclin sagte er wundert sich das ich immer noch einen Timer brauch bezüglich der LED Hardware.

    bis gestern hatte ich noch die LibreELEC 10.0.3 drauf. Damit hatte ich auch noch andere Probleme.

    Ich meine das mit 9.2.8 keine Probleme waren. Hatte dann den Timer von pclin drauf gemacht und es lief dann eigentlich.

    Denke es hängt bei mir mit der 10er Version zusammen von LibreELEC.


    Heute habe ich wieder komplett neu aufgesetzt mit LibreELEC 9.2.8

    LED Hardware ist an auch wenn WLED noch nicht gestartet ist.


    Das auch ohne Timer. Wäre ja super wenns so bleiben könnte.

    Schade nur das ich die 10er dann nicht nehmen kann.?


    Bei meinem anderen Raspi allerdings Version 3 B ist es eben auch so das die LED Hardware immer manuell eingeschaltet werden muss. Aktuell LibreELEC 10.0.4

  • Lord-Grey

    pclin


    So,


    ich habe nun an beiden Raspis die ich habe LibreELEC 9.2.8 aufgespielt

    Alle beide sind Raspberry pi 4

    Danach an beiden Hyperion in der aktuellen Version.


    Nun ist an beiden die LED Hardware an und bleibt auch an.


    Alles ohne Timer.

    Mich würde aber interessieren warum das mit der LibreELEC 10.0.4 nicht klappt.

    Das hat doch eigentlich nichts mit dem Hyperion zu tun?


    Gibt es denn bkannte Probleme mit LibreELEC 10 und Hyperion?


    Gruß

    Tomm

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!