SK6812 LED Issues

  • I recently purchased a 5m strand of SK6812 LEDs, and I'm having issues getting it running with

    I have the strip connected to a 5V 10A power supply and I've tried a few pins on the GPIO pins for the data line, but I can't get the light strip to do anything but light up white. I've tried running this from both a Pi Zero and a Pi 3 Model B with the same results.

    I feel like I'm missing something easy, but I can't figure it out.

    The device settings are as follows:

    Anyone have any ideas on what I might be doing wrong?

  • 3000000 is what it defaulted to when I selected sk6812.

    The results of the spidev_test are as follows:

  • Unfortunately, that did not work. I have added the line to the `/boot/cmdline.txt` file as well as setting the core_freq to 250MHz, and the lights are still bright white and don't respond to any commands that are sent through the interface.

  • I don't know what I did, but they started working. I changed the config to `ws2812spi` and then back to `sk6812spi` and that seemed to kick it into gear.

    The config that ended up working was:

    I'll keep an eye on it moving forward and post back here if I encounter any more issues.

  • What kind of controler you have? Because I have this lights on USB Dreamcolor and setting Adalight and is not working for me, I get mostly only white color. I think because is on USB on Raspberry. I will buy diffrent controler to work on SPI, but I dont know which one?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!