Video capture settings not working?

  • Hello all,

    I recently got all the parts i need for the ambientlights. But somehow they dont work. I looked up a lot of turtorials, did as they told and yet no result. Let me summerize what i have and what i did.

    Raspberry pi 3b+

    WS2812 led strip

    USB 3. hdmi capture card

    and a powerfull enough powersupply


    1) installed raspbian
    * got the latest update ( sudo apt-get update)
    * got the upgrade ( sudo adpt- get upgrade)


    2) Download/instal hyberion.

    * i went to the hyberion release page
    * and downloaded Hyperion-2.0.0-alpha.9-Linux-armv7l.deb

    *then just installed it. Reboot

    3) Gpio activating

    * i ran the following 2 codes

    ( sudo systemctl disable --now hyperiod@pi)

    ( sudo systemctl enable --now hyperiond@root)


    4) hyperion setting

    * i went to te setting set up my ledhardware, as following:

    controller type: wsx281X
    Gpio number: 18 (also the one where i connected data to)

    * i also set the led-layout

    5) Then i went to capture hardware, Enabled usb capture
    At the setting section of usb capture:

    *set device to custom as (/dev/video0)

    5.5) at the effects page i activated boot effect collor as red for 5 seconds.


    When rebooting the pi the effect comes on stays for 5 seconds and turns either to another collor, to nothing or stays on.

    When clicking on the led vizualisation tap under live vieuw, i can see my ps4 screen. Also sometimes when i reboot, and the ps is still on, the live shows snowflakes. The live comes back again after restarting the ps4.

    And yet no ambienlights, it just doesnt work..

    (also i have tried different kind of settings under usb capture but this is the clossest i got)

    Can someone help me with this?

  • Yasirhimself

    Changed the title of the thread from “Video capture setting” to “Video capture settings not working?”.
  • 3) Gpio activating

    * i ran the following 2 codes

    ( sudo systemctl disable --now hyperiod@pi)

    ( sudo systemctl enable --now hyperiond@root)


    not correct>> should be

    sudo systemctl disable --now hyperiond@pi

    sudo systemctl enable --now hyperiond@root

    and don't forget to disable audio


    and do this;

    You need to run hyperion as root with this configuration (device 'ws281x) PWM

    sudo nano /etc/systemd/system/hyperiond@.service

    Remove the User sessionline and save with CTRL+O and exit CTRL+x.

    Don't forget to reboot

  • The first code is donderdag!

    But how do i turn off sound? In terminal?

    Can you be a little bit more specific?

    Im kinda new and dont really understand what i should do. And where to do it

    I am restarting the whole proces.

    what is will do:

    1) flash sd with pi os.

    2) type the following code in config. as you told > dtparam=audio=off

    3) start pi, run update and upgrade command, then reboot
    4) download instal hyperion. reboot

    5) run the followin codes:

    sudo systemctl disable --now hyperiod@pi

    sudo systemctl enable --now hyperiond@root


    And thats as far is i go, lightning guy i need your help!! (im also dutch so maybe its easier to speak dutch or i can move thi topic to dutch forum)

    thank you in advance

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!