Can't get leds to come on

    • Official Post

    wesleymc21 If the LED switch does not stay on, I suggest you lock in the Hyperion Log ("System->Log")

    and see what the error reported is....

    Most likely its is

    LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: mmap() failed'

    Then you need to run Hyperion under root, given your setup and LED type used...

    • Official Post

    Sorry, your post contains bias information...

    If the error is „mmap failed“ as in your posted log-line, then you need to run Hyperion under root, as I told you before.

    If you get a Hardware not supported error as you write in the text, the log should be different and the reason is different too.

    Here the WS281x library requires an update.

    This has been been already fixed in Hyperion’s master. Following options for you:

    1. wait for the next release (no ETA)

    2. build Hyperion yourself

    3. use a development build artifact e.g. from PR1164

    -> It is always beneficial to share more concrete details that the community can help efficiently.

  • oh yeah,s orry. I have my led strip connected to the GPIO18 and if I use a pyhton code it works, but with Hyperion I have the Hardware not supported error

    2021-05-08T15:55:33.830Z [hyperiond LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: Hardware revision is not supported'

    How could I build Hyperion myself or use a development build artifact? (I'm newbie so i''m a bit lost)

  • I don't know if I did something wrong or what but it still doesn't work for me. After compiling, what should I do?

    And I tried using the development artifact 1164 but it says it doesn't exist so i can't use it

  • @icxruus

    u need to adjust toe compile script, after the step of git clone u need to pause the script:

    what i did is:

    git clone --recursive --depth 1 -q ${GIT_REPO_URL} ${CODE_PATH} || { echo "---> Failed to download Hyperion source code! Abort"; exit 1; }
    read -n 1 -r -s -p $'Press enter to continue...\n'   #that line to pause the script
    #Remove previous build area, if no incremental build

    then edit file in separate session



            .hwver = 0xc03114,
            .type = RPI_HWVER_TYPE_PI4,
            .periph_base = PERIPH_BASE_RPI4,
            .videocore_base = VIDEOCORE_BASE_RPI2,
            .desc = "Pi 4 Model B - 4GB v1.4"

    if that is the RP4 u use. then after editing press any key for the compile script to continue :) and it iwll work :D


  • I'm also experiencing the same problem with revision a03115. I tried updating the dependencies but I either couldn't figure it out or it didn't work.

    Here's my log:

    you'll see it has the line "2022-03-02T00:38:13.023Z [LEDDEVICE] (ERROR) Device disabled, device 'ws281x' signals error: 'Failed to open. Error message: Hardware revision is not supported'"

    Here is the info from my pi using cat /proc/cpuinfo

    Hardware    : BCM2835
    Revision    : a03115
    Serial        : 10000000c35ef311
    Model        : Raspberry Pi 4 Model B Rev 1.5

  • See here and for ws281x sudo updateHyperionUser -u root.

    regards pclin

  • Any more suggestions here? I've also followed the steps here with no success. My understanding of github is pretty limited, but I wanted to create a new branch with the necessary dependencies but I couldn't figure out how to do that.

    Frustrating because I want to run emulationstation and hyperion and the pi B+ I have can't handle both. That's why I got the new pi and now it's just a headache. Also just to make sure, I tried installing hyperion on top of raspian lite as well as on top of retropie. Same errors regardless.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!