WS2815 not working with Raspberry Pi

  • H

    I'm having some issues controlling my led strip using Hyperion, it was working perfectly until 2 weeks ago but all of a sudden it stopped working.

    Right now trying to turn on/off the led strip from the dashboard does not affect the led, it just keeps being lit and not turning off nor changing according to the picture from the capture card.

    I checked with 2 different boards (zero/4) and I'm having the same results so I don't think it's a problem with the GPIO.


    The led also seems to turn on when I'm connecting the data pin to GPIO 18 so I don't think there is an issue with the led strip.


    I tried to upgrade to the latest version (2.0.0-alpha.11) and everything seems to be working properly program wise but the led strip just stays turned on and just the first 20 leds.

    I'm not seeing anything out of the ordinary in the logs either.


    That's my log:

    hyperion._log.txt

  • Change the wiring my man.

    Do not power your raspberry via GPIO - there is no voltage protection.

    Get an old usb cable, cut the plug. Two ends connect to power supply the other to raspberry.

    Thanks to this you will get common ground for board and leds - will work. If not we will figure it out ;=)



    WS2815? 2815 needs 12V to work. It wont fire up with 5V!

  • Sure, 8A is enough but still. We have here two power consumers. 12V and 5V. You could use logic shifter but still no explanation why it stopped working... did you check all connections? do you get any light from the strip?

  • I used this calculation from reddit, it worked quit well so I'm guessing it's not an issue with the power supply.



    I did some testing videos and it worked flawlessly

    I'll try to change all the wiring but this is so strange that it worked at first without a Logic Level Shifter and than it worked only with Logic Level Shifter and now it doesn't at all.

    it's so confusing and I was afraid that by updating the os I might had broke something or that might have been an issue with the audio driver and GPIO 18 (PWM).

  • Okay, my mistake. I forgot that you are using a 12V stripe. The formula applies to 5V stripes.


    If you drive the LEDs with PWM, you have to run the Raspberry under user "Root", not "Pi". Are you deactivated the audio driver, that also runs under PWM?

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

  • The interesting part is that I thing in Hyperbian the driver is disabled, The cmd does not work


    Code
    pi@HyperBian:~ $ blacklist snd_bcm2835
    -bash: blacklist: command not found

    and /etc/modules is empty


    Code
    pi@HyperBian:~ $ cat /etc/modules
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.

    So I think that we are all good with the audio driver.


    BTW - thank you all for all the help, I really appreciate it :)

  • im having pretty much the same issue as yael was . im am a complete noob to pi programing. i have been messing with electronics and wiring for years but im lost as hell right now. i am using pi3, ws2815 12volt led strip. i have followed videos and tuttorials on how to set everything up. been looking into this for a week now and i can not get the leds to light

  • execute this command in terminal:


    sudo updateHyperionUser -u root


    then reboot, (to be sure) in config.txt add a line


    dtparam=audio=off




    hardware: make sure the PI and PSU/ledstrip 12 volts have a common ground.


    connect V- of the PSU, 2 GND PIN of PI and GND of ledstrip together.


    get your debuglog and post it here with pastebin :)

  • i have pi on, attached to a screen, can access the terminal but how do i enter that code into it


    ok i found the config and that code is already in there


    have foud out if i unplug the ground from pi to led strip i get 13 leds that lite up white but are not controlable

  • I found this thread while looking for help getting my 4-wire 12V WS2815 LEDs to work on a Raspberry Pi.


    For anyone else looking for the same, the trick was connecting the green Data lead "DI" to GPIO18, the blue "BI" to Ground, and configuring the LEDs in Hyperion as a controller type of "WS281x".

    Hyperion-WS2815-LEDWiring.jpg


    (Sorry about the giant image - I can't find a way of resizing it to something a little less 'shouty'.)


    Hyperion-WS281x.jpg

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!