PicCap - Hyperion Sender App | Ambilight for LG WebOS TVs

  • Es ist aber auch noch genug Reserve in htop zu sehen, und kein Core ist zu 100% ausgelastet.


    Man kann meine Box auch nicht mit dem RPI3b vergleichen, andere Software 6 Cores, 64 Bit und mehr als 5 x schneller. ;)


    gruß pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.12 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin ().

  • Alles im LAN ausser die ESP's.

    Kein pi sondern Dreambox TWO (hyperion-ng 2.0.12) und LG TV (PicCap 0.2.3).

    Beim LG sollte man kein Wlan dafür nutzen!


    gruß pclin

    Dreambox ONE / TWO

    dreamOS OE2.6

    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG OLED65BX9LB (PicCap, hyperion.NG webOS)

    FireTV 4K max

    -
    hyperion (classic) & Plugin HyperionControl | hyperion-ng 2.0.12 (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon


    snoozer_likelinux_manvtkns.gif


    Ambilight for ever

    Edited once, last by pclin ().

  • Evtl. könntest du das installieren, könnte in Lbreelec vorhanden sein, bin mir aber nicht sicher.

    Vermutlich mit sudo apt-get install htop oder du verwendest top anstelle von htop da kannst du auch sehen wieviel CPU hyperiond benötigt.


    gruß pclin

  • OK vergesse ich immer wieder LibreElec hatte ich nur mal kurz auf der Dreambox ausprobiert. ;)


    gruß pclin

  • Hab das Problem gefunden wegen der hohen CPU Auslastung. Auf github wurde das auch mehrfach gemeldet. Ich habe bei allen 4 Instanzen den Start Effekt deaktiviert. Jetzt bin ich bei aktiven usb Grabber bei 30-50%


    Muss dazu sagen das ich noch eine ganz alte Version von Hyperion nutze.


    Heute Abend kann ich dann nochmal mit piccap testen. Vielleicht lag es einfach daran.

  • So ich habe nun den TV am lan.

    Piccap steht auf Most Older 2020

    Auflösung 192x108 mit 30fps



    Jetzt hab ich nur noch eine CPU Auslastung von 15%


    Auch die Verzögerung der LEDs ist besser als vorher aber noch nicht perfekt.


    In Hyperion habe ich folgende Werte unter Glättung:

    Zeit 100

    Aktualisierungsfrequenz 60

    Interpolationsfrequenz 25

    Ausgabefrequenz 25


    Das sind bis jetzt die besten Einstellung.


    Was kann ich noch ändern damit es doch noch 100% flüssig läuft und ich keine Verzögerung mehr habe?


    n0n3m3d88 ich hab auch den pi 3b und wled. Tv und pi sind mit lan verbunden. Ich habe nur mit libdile eine verzögerung, mit libvt+libgm ohne verzögerung und läuft perfekt. Nur bei libvt+libgm ist bei mir dolby vision über shield und hdmi "kaputt". Würde deswegen lieber libdilevt verwenden. Da funzt es. Aber man kann ja nicht alles haben :D

    Welche Werte hast du denn in piccap eingestellt und welche Werte bei Hyperion unter Glättung?

  • n0n3m3d88 bei Piccap hab ich 192 und 108 eingestellt. Bei hyperion habe ich keine glättung drin. Die übergänge sind für mich so top und so läufts bei mir ohne verzögerung mit Old Tv. Kann auch mit 360 und 180 ohne verzögerung aber lasse es bei 192 und 108. Das mit libdile wird hoffentlich auch bald behoben mit der verzögerung. Das geht bei mir wirklich schlecht. ^^

  • Hey zusammen,


    Ich habe jetzt alles eingerichtet aber ich habe immer noch eine kleine Verzögerung mit PicCap denke muss warten bis ein Update raus kommt. Derzeit schaue ich erstmal weiter über usb Grabber.

  • Hallo zusammen

    Wollte mir schon seit längerem ein Ambilight fürs TV zusammenstellen.

    Phillips...zu teuer. Lytmi ... Probleme mit DV etc. Govee ... nicht wirklich.

    Dann kam ich auf Hyperion + PiCap.

    Raspberry 3B hatte ich noch rumliegen, also TV gerootet, PiCap via Homebrew installiert, alles läuft und capture startet auch.

    In PiCap habe ich alles, bis auf die IP natürlich, so gelassen, New TV 2020+, Video und Grapic capture und so.

    Dann, zum testen, in Hyperion eingeloggt, unter "Fernbedienung" wird auch WebOS als aktiv aufgeführt.

    Jetzt Videovorschau aufgerufen und ... nichts oder besser fast nichts.

    Der Vorschaubildschirm bleibt schwarz, egal was ich auf dem FireTV Cube (hängt am AVR) auch aufrufe. Schalte ich allerdings am TV auf "mute" dann erscheint auch das Mute-Symbol in der Vorschau.

    Durch Zufall habe ich dann am TV auf den SAT Eingang gewechselt, an dem nichts ansgeschlossen war.

    Der LG produziert dann kein Schwarzbild sondern so abstrakte Gemälde oder was auch immer und siehe da, die Slideshow wird in der Vorschau wiedergegeben.

    Also das SAT Kabel hinterm Fernseher zusammmengesucht, angeschlossen und .... schwarze Vorschau, nur eben OSD Elemente werden angezeigt !?

    Jemand ne Ahnung was da schief läuft ?


    Achso. Das Setup sieht so aus

    LG OLED65C17LB (WebOS 6.2.0-35) , PiCap 0.2.3 , Raspberry 3B , HyperBian , APA102 (noch nicht angeschlossen)

  • Dann scheint nur Grapic capture und nicht Video Capture bei dir zu funktionieren, keine Ahnung warum.

    Am besten fragst du auf OpenLGTV piccap-hyperion mal nach.


    gruß pclin

  • Danke für den Tip mit Discord.

    Habe jetzt die Auflösung von 360x180 auf 320x180 geändert.

    Damit läuft es.

    Verstehe zwar absolut nicht wieso, aber egal.

    Lagt zwar etwas, aber ich spiele mal mit der Auflösung, mal sehen ob´s was bringt.

  • Moin Leute !


    Ich hoffe ich darf das hier posten.


    Bin gestern auf diesen Beitrag gestoßen uns war sehr erstaunt, was jetzt mit unseren LG Fernsehern möglich ist. Ich habe mich vorher mittels eines RPI3B+ in Verbindung mit einer Kamera herumgequält und bin nie auf ein befriedigendes Ergebnis gekommen. Nun war ich doch schon sehr erstaunt wo ich hier etwas herumgelesen habe und habe mich gleich mal ran gemacht und den TV gerootet und Piccap installiert. Musste jedoch ernüchternd feststellen, dass ich die Verzögerrung beim besten Willen nicht wegbekommen abe. Ob über WLAN oder direkt an LAN angeschlossen, dies machte keinen großen Unterschied.


    Nun bin ich vorhin auf den Beitrag von pclin gestoßen, wo er schrieb man solle mal in den Discord von openlgtv schauen.

    Dort wurde heute Nacht beschrieben, wie man Hyperion selbst auf den TV bringt. Das heißt es wird kein RPI mehr benötigt, alles läuft Intern auf dem TV. Piccap wird hierbei weiterhin benötigt. Ich habe es grade ausprobiert und muss sagen: ES LÄUFT !!! :)


    Keine Verzögerung selbst auf einer Auflösung von 720x480.


    Natürlich muss man noch irgendwie die LED's steuern, ich mache das über einen ESP8266 Node MCU (WLED).


    Ich habe hierzu eine kurze Anleitung geschrieben (jedoch auf Englisch). Ich hänge sie hier mal an.


    Grüße und viel Spaß beim ausprobieren :)

    NeoRoxX

  • Ja und ein Dank an die Hyperion Devs für die Anpassungen die das ermöglicht haben. :thumbup:<3


    gruß pclin

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!