Übersicht/Tests digitale Grabber

  • YUYV ist unkomprimiert hat eine höhere Datenrate, deshalb ist bei hohen Auflösungen und 50/60 Hz nur USB 3.0 in der Lage.

    Ich verwende YUYV einen sichtbaren Unterschied zu MJPG mit hyperion.ng konnte ich aber nicht feststellen.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    Hyperion (classic) & Plugin HyperionControl (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon



    Ambilight for ever

  • Das ist die compilierte Binary, damit kannst du nichts anfangen.


    Code
    cd /
    find |grep hyperiond.sh

    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    Hyperion (classic) & Plugin HyperionControl (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon



    Ambilight for ever

  • OK danke für deine Antwort. Habe meinen zu Beginn auf MJPG umgestellt. Werde mal auf das ursprüngliche YUYV umstellen und testen.

    Du meintest das rein von Bild, Farben Latenz kein Unterschied sein dürfte?

  • Ok, die Änderungen habe ich hinbekommen.

    Nach einem Restart sind allerdings die untenstehenden Daten wieder vorhanden.


    Wie kann ich die Änderungen dauerhaft sichern?


    Andere Frage: Sind 30fps in Ordnung?


  • pclin

    Wie kann ich schnell noch mal auf YUYV umstellen?

    Habe mit

    v4l2-ctl --device=/dev/video0 --set-fmt-video=pixelformat=YUYV

    versucht umzustellen. Es kam keine Fehlermeldung aber der Grabber zeigt immer noch mJpeg

  • Die beiden Zeilen müssen immer einmal vor hyperion start ausgeführt werden.

    Die Default Werte des Grabbers lassen sich nicht dauerhaft im Grabber ändern.

    Sobald der Grabber erkannt wird und Treiber geladen werden sind die Defaukt Werte wieder aktiv.


    Wenn du kein hyperiond.sh  kannst du ein script mit den 2 Zeilen erstellen und das beim systemstart ausführen lassen.

    Oder man ruft den Script mit dem hyperiond.service.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    Hyperion (classic) & Plugin HyperionControl (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon



    Ambilight for ever

  • Wenn der Grabber aktiv von z.B. hyperion genutzt wird kannst du nicht das Pixelformat mit v4l2-ctl umschalten.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    Hyperion (classic) & Plugin HyperionControl (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon



    Ambilight for ever

  • Hi pclin


    Ich habe unter


    /storage/.kodi/addons/service.hyperion/system.d

    die Datei


    service.hyperion.service


    Darin ist folgendes enthalten:


    Kannst du mir helfen wo ich da die beiden Zeilen eintragen muss ?

  • Du machst am besten einen ausführbaren Script mit den beiden Zeilen.


    Dann vor ExecStart eine Zeile einfügen

    Code
    ExecStartPre=/path/zum/script/script_name

    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    Hyperion (classic) & Plugin HyperionControl (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon



    Ambilight for ever

  • Hallo Zusammen,


    ich habe mir folgenden Grabber gekauft, weil dieser hier von einem User auch empfohlen wurde: Composite USB 2.0 Grabber UTVF007


    Folgende Werte habe ich ausgelesen:


    Umgebung: Raspberry Pi Model B Rev 2

    Hyperion: Classig

    Ich habe den USB-Grabber-Stick, wegen der USB Stromversorgung, an einen USB-HUB angeschlossen. Das System Funktioniert auch einwandfrei mit dem analogen Grabber.


    Mit dem neuen digitalen Grabber funktioniert es nicht.

    In der Hyperion Classig Konsole habe ich noch keine Änderung wegen dem neuen digitalen Stick vorgenommen, ich wüsste auch nicht was bzw. wollte erst auf eure Meinung warten.

    Sicherlich habe ich irgendetwas vergessen, entweder funktioniert der neue Digitale Stick nicht mit der Classig Version oder ich habe eine Einstellung vergessen, hat eventuell jemand von euch eine Idee?


    PS. Ich habe mir mit den Infos sehr viel Mühe gegeben, ich denke dafür habe ich ein Lob verdient :):):) (kleiner Scherz)

  • Sicherlich habe ich irgendetwas vergessen, entweder funktioniert der neue Digitale Stick nicht mit der Classig Version oder ich habe eine Einstellung vergessen, hat eventuell jemand von euch eine Idee?

    Was läuft denn auf deinem RasPi als System und ist das auf dem aktuellsten Stand? Vielleicht auch mal einen anderen USB-Port wählen bzw. den HDMI-Stick direkt an den RasPi anschliessen.


    Dann würde ich persönlch zu Hyperion NG wechseln, einfach auf eine separate Micro SD-Karte installieren und testen ob dort der Stick erkannt wird.

  • Für heute habe ich erst einmal aufgegeben ?(


    Selbst unter NG bekomme ich den neuen USB-Grabber nicht zum laufen. Die ganzen Befehle die ich absetze sehen gut aus, der Hyperion-Status sieht gut aus, via Platform habe ich unter NG die LEDs zum Leuchten bekommen. Habe den neuen Grabber auch direkt und über den USB-Hub angeschlossen -> Negativ. Ich werde es noch ein zwei Tage damit versuchen ansonsten geht der wieder zurück. Habe erst einmal Classik wieder aktiviert und läuft ;-)

  • Hab folgendes Setup:


    NVidia Shield ---> Marantz SR6014 ---> EZCOOTECH EZ-SP12HAS ---> Sony 77 AG9

    ...........................................................................................................\---> WIKIMN JP-ZJX11 ---> RPi2 mit Ambi-TV (bzw Hyperion) --> 7,50m SK6812 LED Stripe


    Läuft mit SDR, HDR und DV !


    Der Grabber wird ohne Downscaling mit dem 4k Signal befeuert, und mit 720x480 YUYV 30fps ausgelesen

  • Nachdem ich heute alles mögliche mit meinen neuen USB-Grabber unter Hyperion-NG und mit dem HyberBian-Image ausprobiert habe, hatte ich die Faxen dicke und habe vier neue Grabber bestellt, irgendeiner wird wohl funktionieren.


    Schön wenn man alles wieder zurück baut und unter Classic geht das Licht wieder an :)

  • Quote
    ich habe mir folgenden Grabber gekauft, weil dieser hier von einem User auch empfohlen wurde: Composite USB 2.0 Grabber UTVF007


    Hi,


    der zumindest, ist schon mal kein Digitaler. ;) Ist ein alter UTFV007, der den HDMI/Analog Wandler halt in seinem Gehäuse integriert hat. Wenn du eh 4 neue bestellt hast, wird schon was passendes bei sein. Sobald der Grabber 1080p recorden (nicht nur entgegennehmen) kann, passt das schon.


    Grüße

    Micha

  • Ich habe hier den Rullz USB 3.0 Loop U3 mit Optical Out https://www.aliexpress.com/ite…SB-2-0/4001294726740.html


    Er funktioniert nicht gescheit. Gekauft wegen dem zusätzlichen AudioOut


    -Wem am Loop Out kein Gerät hängt, wird nur 1080p/60Hz angenommen.

    -CEC kann er nicht

    -Das Bild wird star die Linke Obere Ecke angenommen, der rest wird abgeschnitten 4k/1080p-->720/480 (Am PC geht es)

    -die EDID wird vom TV/zuspieler Kopiert und wird erst wieder geändert wenn er stromlos war, man kann also zwischendurch nicht die Auflösung der Quelle/TV ändern

  • TangoCash Habe mich grade dank deinem Post hier angemeldet. Bin aktuell auch dabei ein Ambilight aufzubauen, habe jedoch ein etwas kompliziertes Set Up. Da kommt mir deine Lösung gerade recht. Hast du vielleicht noch ein paar Infos welche Software du auf dem Raspi nutzt? Oder noch besser, ein Tutorial wie man das ganze einrichtet. Oder hast du dir alles selbst erarbeitet und ausprobiert?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!