Hyperion NG LEDs leuchten einfach nicht

  • Hallo zusammen,


    nun ich habe schon paar Wochen versucht etwas zu finden. Im Netz und hier bin ich leider nicht fündig geworden.


    Mein erstes System ist Openelec mit Pi2, Hyperion und WS2801 LED´s.

    Das System funktioniert auch


    zweites System am LG Tv

    Pi3 mit Libreelec, Hyperion NG und ebenfalls WS2801 LED´s


    Was nicht funktioniert:

    Nach dem einschalten leuchten paar LED´s bis der Pi hochgefahren ist und gehen dann alle aus.

    Ich denke das alle soweit passt, nur die LED´s wollen nicht wie sie sollen. Bleibt alles dunkel.

    Die Konfiguration ist fast die selbe wie beim ersten System das fehlerfrei läuft. Nur eben weniger LED´s.


    Grabber Funktioniert und liefert auch entsprechend ein Bild. (Siehe Anhang)



    Ich weis einfach nicht mehr weiter...

    Jemand ne Idee was ich noch prüfen kann?

  • Go to Best Answer
  • Guten morgen Lord,


    hier die Ausgabe...


    2019-04-11T16:28:41.728Z [hyperiond DAEMON] (INFO) CEC handler created 2019-04-11T16:28:41.767Z [hyperiond EFFECTFILES] (INFO) 39 effects loaded from directory :/effects/ 2019-04-11T16:28:41.780Z [hyperiond EFFECTFILES] (INFO) 22 effect schemas loaded from directory :/effects/schema/ 2019-04-11T16:28:41.788Z [hyperiond EFFECTFILES] (INFO) 0 effects loaded from directory /storage/hyperion/custom-effects 2019-04-11T16:28:41.945Z [hyperiond DAEMON] (INFO) set screen capture device to 'dispmanx' 2019-04-11T16:28:41.949Z [hyperiond DISPMANXGRABBER] (INFO) Display opened with resolution: 1360x768 2019-04-11T16:28:41.950Z [hyperiond DAEMON] (INFO) DISPMANX frame grabber created 2019-04-11T16:28:41.953Z [hyperiond V4L2:AUTO] (INFO) Signal threshold set to: {12, 12, 12} 2019-04-11T16:28:41.953Z [hyperiond V4L2:AUTO] (INFO) Cropping image: width=0 height=0; crop: left=10 right=10 top=7 bottom=7 2019-04-11T16:28:41.953Z [hyperiond V4L2:AUTO] (INFO) Signal detection area set to: 0.250000,0.250000 x 0.750000,0.750000 2019-04-11T16:28:41.996Z [hyperiond JSONSERVER] (INFO) Started on port 19444 2019-04-11T16:28:41.951Z [hyperiond CEC] (INFO) Starting CEC handler 2019-04-11T16:28:41.959Z [hyperiond LEDDEVICE] (INFO) Start LedDevice 'ws2801'. 2019-04-11T16:28:41.980Z [hyperiond FLATBUFCONN] (INFO) Connecting to Hyperion: 127.0.0.1:19401 2019-04-11T16:28:41.998Z [hyperiond EFFECTENGINE] (INFO) Run effect "Rainbow swirl fast" on channel 0 2019-04-11T16:28:42.027Z [hyperiond FLATBUFSERVER] (INFO) Started on port 19400 2019-04-11T16:28:42.029Z [hyperiond PROTOSERVER] (INFO) Started on port 19445 2019-04-11T16:28:42.143Z [hyperiond HYPERION] (INFO) Initial foreground effect 'Rainbow swirl fast' started 2019-04-11T16:28:42.148Z [hyperiond V4L2:AUTO] (INFO) available V4L2 devices:
    /dev/video0 usbtv
    2019-04-11T16:28:42.148Z [hyperiond V4L2:AUTO] (INFO) search for usable video devices 2019-04-11T16:28:42.149Z [hyperiond V4L2:AUTO] (INFO) test v4l device: /dev/video0 2019-04-11T16:28:42.169Z [hyperiond V4L2:AUTO] (INFO) found usable v4l2 device: /dev/video0 (usbtv) 2019-04-11T16:28:42.240Z [hyperiond V4L2:AUTO] (INFO) Started 2019-04-11T16:28:42.241Z [hyperiond HYPERION] (INFO) Hyperion instance 'Schlafzimmer' has been started 2019-04-11T16:28:42.301Z [hyperiond WEBSERVER] (INFO) Started on port 8090 name 'Hyperion Webserver' 2019-04-11T16:28:42.565Z [hyperiond CEC] (INFO) Auto detecting CEC adapter 2019-04-11T16:28:42.565Z [hyperiond CEC] (INFO) CEC Adapter: 2019-04-11T16:28:42.566Z [hyperiond CEC] (INFO) Name : RPI 2019-04-11T16:28:42.566Z [hyperiond CEC] (INFO) Path : Raspberry Pi 2019-04-11T16:28:42.679Z [hyperiond WEBSERVER] (INFO) Started on port 8092 name 'Hyperion Webserver' 2019-04-11T16:28:44.479Z [hyperiond CEC] (INFO) CEC Handler initialized with adapter : RPI 2021-04-02T07:47:15.124Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: disabled 2021-04-02T07:47:15.142Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1063:handleLoggingCommand()) log streaming deactivated for client ::ffff:172.16.10.21 2021-04-02T07:47:17.323Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: enabled 2021-04-02T07:47:20.086Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:172.16.10.21

  • Wenn das so richtig , smothing abgeschaltet und Pi neu gestartet...



    2019-04-11T16:28:43.756Z [hyperiond DAEMON] (INFO) CEC handler created 2019-04-11T16:28:43.798Z [hyperiond EFFECTFILES] (INFO) 39 effects loaded from directory :/effects/ 2019-04-11T16:28:43.810Z [hyperiond EFFECTFILES] (INFO) 22 effect schemas loaded from directory :/effects/schema/ 2019-04-11T16:28:43.822Z [hyperiond EFFECTFILES] (INFO) 0 effects loaded from directory /storage/hyperion/custom-effects 2019-04-11T16:28:43.914Z [hyperiond SETTINGSMGR] (DEBUG) (SettingsManager.cpp:109:SettingsManager()) Settings database initialized 2019-04-11T16:28:43.920Z [hyperiond BLACKBORDER] (DEBUG) (BlackBorderProcessor.cpp:64:handleSettingsUpdate()) Set mode to: default 2019-04-11T16:28:43.920Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Blackborder detector: enabled 2019-04-11T16:28:43.982Z [hyperiond DAEMON] (INFO) set screen capture device to 'dispmanx' 2019-04-11T16:28:43.982Z [hyperiond DISPMANXGRABBER] (DEBUG) (Grabber.cpp:30:setVideoMode()) Set videomode to 0 2019-04-11T16:28:43.986Z [hyperiond DISPMANXGRABBER] (INFO) Display opened with resolution: 1360x768 2019-04-11T16:28:43.986Z [hyperiond DISPMANXGRABBER] (DEBUG) (Grabber.cpp:90:setWidthHeight()) Set new width: 80, height: 45 for capture 2019-04-11T16:28:43.987Z [hyperiond DAEMON] (INFO) DISPMANX frame grabber created 2019-04-11T16:28:43.988Z [hyperiond V4L2:AUTO] (DEBUG) (Grabber.cpp:30:setVideoMode()) Set videomode to 0 2019-04-11T16:28:43.990Z [hyperiond V4L2:AUTO] (INFO) Signal threshold set to: {12, 12, 12} 2019-04-11T16:28:43.990Z [hyperiond V4L2:AUTO] (INFO) Cropping image: width=0 height=0; crop: left=10 right=10 top=7 bottom=7 2019-04-11T16:28:43.991Z [hyperiond V4L2:AUTO] (INFO) Signal detection area set to: 0.250000,0.250000 x 0.750000,0.750000 2019-04-11T16:28:43.991Z [hyperiond DAEMON] (DEBUG) (hyperiond.cpp:630:handleSettingsUpdate()) V4L2 grabber created 2019-04-11T16:28:44.008Z [hyperiond JSONSERVER] (DEBUG) (JsonServer.cpp:28:JsonServer()) Created instance 2019-04-11T16:28:44.025Z [hyperiond JSONSERVER] (INFO) Started on port 19444 2019-04-11T16:28:43.988Z [hyperiond CEC] (INFO) Starting CEC handler 2019-04-11T16:28:43.997Z [hyperiond LEDDEVICE] (INFO) Start LedDevice 'ws2801'. 2019-04-11T16:28:43.997Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Smoothing: enabled 2019-04-11T16:28:43.998Z [hyperiond SMOOTHING] (DEBUG) (LinearColorSmoothing.cpp:701:selectConfig()) cfg [0]: Type: linear - Time: 200 ms, outputRate 25.000000 Hz, interpolationRate: 25.000000 Hz, timer: 40 ms, Dithering: 0, Decay: 1.000000 -> HalfTime: 100.000000 ms 2019-04-11T16:28:43.999Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:148:init()) deviceConfig: [{"colorOrder":"rgb","currentLedCount":85,"hardwareLedCount":85,"invert":true,"latchTime":0,"output":"/dev/spidev0.0","rate":1e+06,"rewriteTime":1000,"type":"ws2801"}] 2019-04-11T16:28:44.001Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:407:setLatchTime()) LatchTime updated to 0ms 2019-04-11T16:28:44.002Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:428:setRewriteTime()) Refresh interval = 1000ms 2019-04-11T16:28:44.003Z [hyperiond LEDDEVICE] (DEBUG) (LedDevice.cpp:434:setRewriteTime()) RewriteTime updated to 1000ms 2019-04-11T16:28:44.004Z [hyperiond LEDDEVICE] (DEBUG) (ProviderSpi.cpp:45:init()) _baudRate_Hz [1000000], _latchTime_ms [0] 2019-04-11T16:28:44.005Z [hyperiond LEDDEVICE] (DEBUG) (ProviderSpi.cpp:46:init()) _spiDataInvert [1], _spiMode [0] 2019-04-11T16:28:44.009Z [hyperiond SMOOTHING] (DEBUG) (LinearColorSmoothing.cpp:701:selectConfig()) Previous line repeats 1 times 2019-04-11T16:28:44.010Z [hyperiond FLATBUFCONN] (INFO) Connecting to Hyperion: 127.0.0.1:19401 2019-04-11T16:28:44.026Z [hyperiond EFFECTENGINE] (INFO) Run effect "Rainbow swirl fast" on channel 0 2019-04-11T16:28:44.051Z [hyperiond FLATBUFSERVER] (INFO) Started on port 19400 2019-04-11T16:28:44.053Z [hyperiond PROTOSERVER] (INFO) Started on port 19445 2019-04-11T16:28:44.059Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:33:initServer()) Initialize Webserver 2019-04-11T16:28:44.062Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:33:initServer()) Initialize Webserver 2019-04-11T16:28:44.181Z [hyperiond EFFECTENGINE] (DEBUG) (EffectEngine.cpp:183:runEffectScript()) Start the effect: name [Rainbow swirl fast], smoothCfg [2] 2019-04-11T16:28:44.181Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:161:registerInput()) Register new input 'System/EFFECT' with priority 0 as inactive 2019-04-11T16:28:44.183Z [hyperiond HYPERION] (INFO) Initial foreground effect 'Rainbow swirl fast' started 2019-04-11T16:28:44.185Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:161:registerInput()) Register new input 'System/V4L' with priority 240 as inactive 2019-04-11T16:28:44.185Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) V4L capture device: enabled 2019-04-11T16:28:44.190Z [hyperiond V4L2:AUTO] (INFO) available V4L2 devices:
    /dev/video0 usbtv
    2019-04-11T16:28:44.191Z [hyperiond V4L2:AUTO] (INFO) search for usable video devices 2019-04-11T16:28:44.192Z [hyperiond V4L2:AUTO] (INFO) test v4l device: /dev/video0 2019-04-11T16:28:44.205Z [hyperiond V4L2:AUTO] (DEBUG) (V4L2Grabber.cpp:601:init_device()) Video standard=PAL 2019-04-11T16:28:44.206Z [hyperiond V4L2:AUTO] (DEBUG) (V4L2Grabber.cpp:696:init_device()) Set resolution to width=720 height=576 2019-04-11T16:28:44.206Z [hyperiond V4L2:AUTO] (DEBUG) (V4L2Grabber.cpp:735:init_device()) Pixel format=YUYV 2019-04-11T16:28:44.213Z [hyperiond V4L2:AUTO] (INFO) found usable v4l2 device: /dev/video0 (usbtv) 2019-04-11T16:28:44.275Z [hyperiond V4L2:AUTO] (INFO) Started 2019-04-11T16:28:44.277Z [hyperiond V4L2:auto] (DEBUG) (GrabberWrapper.cpp:48:start()) Grabber start() 2019-04-11T16:28:44.186Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:161:registerInput()) Register new input 'System/GRABBER' with priority 250 as inactive 2019-04-11T16:28:44.186Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) Framegrabber: enabled 2019-04-11T16:28:44.280Z [hyperiond Dispmanx] (DEBUG) (GrabberWrapper.cpp:48:start()) Grabber start() 2019-04-11T16:28:44.187Z [hyperiond BOBLIGHT] (DEBUG) (BoblightServer.cpp:28:BoblightServer()) Instance created 2019-04-11T16:28:44.285Z [hyperiond HYPERION] (INFO) Hyperion instance 'Schlafzimmer' has been started 2019-04-11T16:28:44.188Z [hyperiond COMPONENTREG] (DEBUG) (ComponentRegister.cpp:36:setNewComponentState()) LED device: enabled 2019-04-11T16:28:44.322Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:91:handleSettingsUpdate()) Apply Webserver settings 2019-04-11T16:28:44.322Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:91:handleSettingsUpdate()) Apply Webserver settings 2019-04-11T16:28:44.323Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:109:handleSettingsUpdate()) Set document root to: :/webconfig 2019-04-11T16:28:44.323Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:109:handleSettingsUpdate()) Set document root to: :/webconfig 2019-04-11T16:28:44.324Z [hyperiond WEBSERVER] (INFO) Started on port 8090 name 'Hyperion Webserver' 2019-04-11T16:28:44.347Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:251:setInputImage()) Priority 240 is now active 2019-04-11T16:28:44.347Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:351:setCurrentTime()) Set visible priority to 0 2019-04-11T16:28:44.348Z [hyperiond SMOOTHING] (DEBUG) (LinearColorSmoothing.cpp:701:selectConfig()) cfg [2]: Type: linear - Time: 200 ms, outputRate 25.000000 Hz, interpolationRate: 25.000000 Hz, timer: 40 ms, Dithering: 0, Decay: 1.000000 -> HalfTime: 100.000000 ms 2019-04-11T16:28:44.348Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:559:handlePriorityChangedLedDevice()) priority[0], previousPriority[255] 2019-04-11T16:28:44.349Z [hyperiond HYPERION] (DEBUG) (Hyperion.cpp:569:handlePriorityChangedLedDevice()) new source available -> switch LED-Device on 2019-04-11T16:28:44.390Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:251:setInputImage()) Priority 250 is now active 2019-04-11T16:28:44.607Z [hyperiond HYPERION] (DEBUG) (PriorityMuxer.cpp:251:setInputImage()) Priority 0 is now active 2019-04-11T16:28:44.676Z [hyperiond CEC] (INFO) Auto detecting CEC adapter 2019-04-11T16:28:44.676Z [hyperiond CEC] (INFO) CEC Adapter: 2019-04-11T16:28:44.676Z [hyperiond CEC] (INFO) Name : RPI 2019-04-11T16:28:44.677Z [hyperiond CEC] (INFO) Path : Raspberry Pi 2019-04-11T16:28:44.685Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:175:handleSettingsUpdate()) Setup SSL certificate 2019-04-11T16:28:44.688Z [hyperiond WEBSERVER] (DEBUG) (WebServer.cpp:191:handleSettingsUpdate()) Setup private SSL key 2019-04-11T16:28:44.689Z [hyperiond WEBSERVER] (INFO) Started on port 8092 name 'Hyperion Webserver' 2021-04-02T10:14:17.088Z [hyperiond CEC] (INFO) CEC Handler initialized with adapter : RPI 2021-04-02T10:14:21.542Z [hyperiond WEBSOCKET] (DEBUG) (WebSocketClient.cpp:30:WebSocketClient()) New connection from ::ffff:172.16.10.21 2021-04-02T10:14:21.543Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:81:handleInstanceSwitch()) Client '::ffff:172.16.10.21' switch to Hyperion instance 0 2021-04-02T10:14:33.557Z [hyperiond WEBSOCKET] (DEBUG) (JsonAPI.cpp:1054:handleLoggingCommand()) log streaming activated for client ::ffff:172.16.10.21

  • Nein das habe ich noch nicht. Da es 2 verschiendene Systeme sind.

    pi2 hat Openelec mit dem alten Hyperion

    pi3 libreelec und Hyperion NG.


    Am pi3 hatte ich schon alles mögliche getestet.

    Ebefalls auch das Openelec mit dem alten Hyperion, so ich es eignetlich schon habe.

    Sind eben nur mehr LED´s als jetzt beim neuen TV.

  • Ja, sind zwei verschiedene SoftwareäSysteme aber vom Aufbau her ja identisch. Du kannst ja mal schauen ob das Setting mit der RAsPi2-Karte auf dem RasPi3 funktioniert und anders rum. Am System selbst verstellst du ja nichts.


    Meiner Logik nach: wenn die Verkabelung auf beiden Systemen in Ordnung sein sollte, dann leuchten beide. Wenn nicht, dann sollte zumindest der RasPi2 (mit der Karte des RasPi3) leuchten.

  • So,

    die Karte aus dem Pi3 in den Pi2 gesteckt --> LED´s leuchten wenn der Pi hochgefahren ist. Kein Effekt und auch sonst nichts.


    Die Karte aus dem Pi2 in den Pi3 gesteckt --> LED´s bleiben dunkel ...


    ich werde nun mal versuchen zu schauen ob eventuell die Lötstellen des Steckers was haben.

    Habe es nicht selbst gelötet, war schon fertig.

  • Update....

    Es war tatsächlich so das der Pin der LED Strippe bei GND nicht sauber gelötet war.

    Jetzt leuchten die LED´s aber noch nicht wie sie sollen.


    Es fehlt jetzt noch der Effekt beim einschalten und die LED´s entsprechen der Quelle.

    Hier ist nur eine Quelle HDMI vom Telekom Receiver.

  • Jetzt läuft es. :)


    Es kann so einfach sein. Dank Lightstripper mit dem Kartentausch bin ich auf die Idee gekommen die Lötpunkte zu prüfen der Strippe.


    Das jetztdas Ambilight läuft war nur noch der Fehler in der Konfig...

    Invertiertes Signal war ein haken drin....


    Update:

    Ambilight läuft nicht mehr. Es lief tatsächlich nur 1-2 Tage.

    Die LED´s leuchten zwar aber das nur wenn das Netzteil deer LED´s an geht.


    Und nun komme ich auf das Webinterface von Hyperion.ng auch nicht mehr drauf.


    ERR_CONNECTION_REFUSED

  • ThoRiWa

    Added the Label SOLVED

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!