Ambilight startet nicht auf Pi2

  • http://powerpi.de/atemberauben…rry-pi-2-tutorial-teil-1/Hallo Ihr "Erleuchteten"


    leider ist meine Thema-Überschrift nicht die allerbeste, aber was besseres fällt mir nicht ein!

    Da ich nach längerem stöbern hier den Eindruck habe dass mir evtl. geholfen werden kann, wende ich mich nun mal an Experten.

    Da ich mich programmiertechnisch nur etwas bei Siemens-SPS auskenne, nehmt es mir bitte nicht übel wenn ich da nicht gleich durchsteige bzw. beim schreiben dieses Textes schon meinen bayerischen Sprachhorizont überqueren muss.

    Ich hatte seit März 2016 Ambilight-System laufen welches sich nur gelegentlich aufhing, letztendlich aber vermutlich wegen defekter Drahtisolierungen im USB-Videograbber zum Totalversagen kam.


    Aber der Reihe nach zuerst meine Hardware:

    Raspberry Pi 2 Model B V1.1 (2014)

    SanDisk Ultra 32GB microSDHC Class10

    MeanWell RS-50-5 (+5V, 10A)

    WS2801-5050FC32-CV

    CSL, Mod.-Nr.:43628/20151117SZ090, HDMI Splitter 1X2, 1.3V

    Liqoo Mini HDMI2AV

    LogiLink VG0001A

    No-Name Chinch Adapter von Ebay

    und aktuell intallierte Software: LibreELEC-RPi2.arm-9.2.8


    Habe damals die aufwändige Variante von power-pi.de installiert (gab damals nix anderes) auf eine 8 GB-Karte. Da ich dieses nicht mehr zum laufen bringe (WindowsXP, fehlende Internetlinks...) habe ich schon sehr sehr viel Zeit (>28h) in verschiedene Optionen gesteckt, bin aber immer gescheitert (habe folgende Varianten ausprobiert: http://powerpi.de/atemberauben…rry-pi-2-tutorial-teil-1/ und https://tutorials-raspberrypi.…lle-geraete-selber-bauen/. und https://digitalewelt.at/ambili…t-fuer-schritt-anleitung/ ).

    Mein Erfolg geht immer bis zum Übertragen der Dateien zum Raspberry (via SD-Karte, PuTTY, Sublime Text, FileZilla), auch das Erstellen der hyperion.config.json ist kein Problem. Das letzte was bei mir noch funktioniert ist "Hole Bild vom Grabber" in HyperCon. "Sende Farbe" geht schon nicht mehr.

    Einen Hardwaredefekt schließe ich aus, denn der Rainbowflash der LED's beim Starten des Raspberry funktioniert, auch die Farbsteuerung via Hyperion-App (alt/eingeschränkt) vom Handy aus. Vom HDMI-Eingangssignal in den Raspberry dürfte auch alles passen sonst ginge das "Bild holen" in HyperCon nicht.

    Fehlt es da doch nur an einer klitzekleinen Datei oder Einstellung?

    Bin für alle Hilfestellungen dankbar. (Aber bitte mit Erklärung was und wie ich Informationen posten soll).


    Auf dass es wieder hell erstrahlt an der Wand :)


    Grüße aus der Oberpfalz

    Jürgen

  • Hallo,

    Dir ist schon bewusst, dass du einem Tutorial von 2016 gefolgt bist? Hyperion Classic mit Hypercon wird schon lange nicht mehr unterstützt. Die aktuelle heißt Hyperion.NG und vor kurzem ist das neue Release 2.0 Alpha 10 herausgekommen. Alle Infos findest du ganz oben unter Dokumentation.

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

  • Danke Mike72,

    hab mich da mal durchgelesen und probiere es mal aus.

    In der Anleitung sind allerdings die drei Link tot, die in der Installationsbeschreibung von HyperBian wie man das Image auf die SD-Karte schreibt. Werde es mit Win32DiskImager durchführen


    Grüße aus der Oberpfalz

  • Genau, das heruntergeladene HyperBian.zip entpacken und das HyperBian-lite.img auf die microSD flashen.

    Ich verwende dazu immer den Raspberry Pi Imager. Würde dazu aber gleich eine größere Karte als 4GB empfehlen.

    Ob dein Pi 2 dann das ganze packt kann ich dir nicht beantworten. Kommt halt drauf an was auf dem RPi später alles laufen soll...?

    Auch ob du ein FullHD oder 4K Setup hast...? Du wirst vermutlich sowieso noch einiges an neuer Hardware brauchen. Die analoge HDMI2AV & Grabber-Lösung ist auch nicht mehr das wahre, mittlerweile gibt's recht günstige HDMI2USB Capture Cards, dazu hier mehr. Auch bei den LEDs hat sich einiges getan. Viel Glück!:thumbup:

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

    Edited 3 times, last by Mike72 ().

  • und aktuell intallierte Software: LibreELEC-RPi2.arm-9.2.8

    Am einfachsten ist wenn du dir das passende Image von LibreElec runter lädst. Das Image dann auf die SD-Karte schreibst und dann erstmal Kodi einrichtest.


    Ist das alles getan, dann loggst du dich via SSH auf deinen RasPi ein und installierst mit dem Script von Paulchen-Panther Hyperion.ng

    Einfach diese Zeile reinkopieren, Rest läuft automatisch ab.

    Code
    wget -qO- https://git.io/JU4Zx | bash

    Danach kannst du über einen Browser auf das Web-Frontend von Hyperion.ng zugreifen (IP des RasPi und den jeweiligen Port, Standard ist 8090) und es nach deinen Bedürfnissen konfigurieren.

  • Danke Lightstripper,


    Ich habe lediglich das auf die SD-Karte geschrieben wie es hier beschrieben ist. Sonst nix.

    Nachdem ich gestern die Led's endlich zum leuchten gebracht habe, und die Konfiguration mit Hyperion geschafft, verzweifle ich heute jetzt langsam.

    Und deine Aussage trägt auch noch mehr dazu bei, den mit dem Script (?) via ssh (vlt. PuTTY?) den Code (wo und wie "reinkopieren"). Das überfordert mich momentan. Brauch ich vorher Kodi? Und das ist schon was anderes als HyperBian?

    Ich will eigentlich nur ein einfaches Ambilight laufen haben.


    Bei mir zeigt der Fernseher (wenn ich HDMI3, da wo der Raspberry angeschlossen ist wähle, aber auch nur diese "Programmiererzeilen an. Da ging gestern noch der HyperBian login: pi mit Password: raspberry. Der geht heute aber nicht mehr nachdem ich den PI mit dem Befehl reboot neu gestartet habe (vlt. zieh ich die Probleme auch an oder bin zu doof).

    Wollte da nur einen anderen UAS-Grabber ausprobieren, welcher auch arbeitet nachdem ich in der Konfiguration umgestellt habe.

    (Notfalls mache ich das mit dem Image auf SD-Karte nochmal)


    Ist leider eine schwere Geburt mit mir. Mein englisch endete leider auch in der 9. Klasse, kam bisher aber ohne ganz gut durchs Leben. Ideal wäre für mich ein Anleitung die der DAU auch schaffen würde :)

  • Ich will eigentlich nur ein einfaches Ambilight laufen haben.

    Dann reicht HyperBian. LibreELEC ist dann sinnvoll, wenn zusätzlich Kodi als Mediaplayer laufen soll. Deine Entscheidung.


    Edit: Die HDMI-Verbindung vom Raspberry zum TV benötigst du nur zur Einrichtung. Nachher läuft der headless, also ohne Monitor bzw. TV. Die Konfiguration erfolgt per WebUI über einen Browser deiner Wahl.


    Beschreibe am besten, an welchem Punkt du nicht mehr weiterkommst. Dann gehen wir Schritt für Schritt durch.:thumbup:

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

    Edited once, last by Mike72 ().

  • Und deine Aussage trägt auch noch mehr dazu bei, den mit dem Script (?) via ssh (vlt. PuTTY?) den Code (wo und wie "reinkopieren"). Das überfordert mich momentan. Brauch ich vorher Kodi? Und das ist schon was anderes als HyperBian?

    Ich will eigentlich nur ein einfaches Ambilight laufen haben.

    Mit dem LibreElec Image hast du alles was du brauchst; es beinhaltet ein schlankes OS und den Mediaplayer Kodi. So wird es auch "beworben": Just enough OS for Kodi!


    Ja, über ein Terminalprogramm wie z.B. PuTTY loggst du dich von deinem PC in den RasPi ein.


    User: root

    PW: libreelec


    Dann einfach diese Zeile abtippen/kopieren:

    Code
    wget -qO- https://git.io/JU4Zx | bash

    Mehr braucht es wirklich nicht für Ambilight.

  • in Verbindung mit einem USB-Grabber braucht, warum willst du ihm dann unbedingt LibreELEC auf's Auge drücken?

    Du hast schon recht, einfaches Linux drauf und hyperion.ng installiert reicht aus.


    Aber LibreElec zu installieren und Kodi dann mit zu benutzen schadet ja auch nicht sondern bietet mehr Möglichkeiten. Und er hatte ja die aktuellste Kodi (Leia) Installation auch drauf. Vielleicht benutzt er Kodi ja auch auf seinem Raspi?


    Viel geht ja nicht daraus hervor und ich habe so das Gefühl, dass er es sich in einigen Bereichen verkompliziert.


    Diese drei Teile: Liqoo Mini HDMI2AV, LogiLink VG0001A und No-Name Chinch Adapter von Ebay


    würde ich z.b. auch gegen einen günstigen HDMI2USB Stick tauschen. Weniger Geräte = weniger Fehlerquellen + weniger Kabel und bessere Qualität.

  • Diese drei Teile: Liqoo Mini HDMI2AV, LogiLink VG0001A und No-Name Chinch Adapter von Ebay


    würde ich z.b. auch gegen einen günstigen HDMI2USB Stick tauschen. Weniger Geräte = weniger Fehlerquellen + weniger Kabel und bessere Qualität.

    :thumbup:

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

  • Habe jetzt die SD-Karte nochmal beschrieben und ssh aktiviert.

    (Kann mich aber in den Pi auf dem Fernseher nicht einloggen da das Passwort falsch ist, was aber gestern ging)

    Bekommen jetzt auch Farben an die Wand die sich mit dem Fernsehbild ändern, allerdings stimmt da keine überein. Das mit dem Zauberstab hab ich gemacht, somit ist rot rot und grün grün.

    Da fehlt es bestimmt krass an irgendwelchen Einstellungen!

    Die runtergeladenen Testbilder aus der zip-Datei weiß ich nicht wie ich die Anzeigen lassen kann.

    Wollte mich informieren was der HDMI2USB Stick ist, sogar da finde ich nur Adapter Konverter 1080P Monitor Windows Black . Wenn das meine Probleme löst hab ich das morgen.

  • Kann mich aber in den Pi auf dem Fernseher nicht einloggen da das Passwort falsch ist, was aber gestern ging

    Auf dem Standard Tastaturlayout (englisch) ist z mit y vertauscht. Vlt liegts daran?


    Der von dir verlinkte ist übrigens ein USB zu HDMI-Adapter, du brauchst genau das Gegenteil z.B. sowas.


    Wir wissen auch noch nicht ob du einen FullHD- oder 4K-TV hast?

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

    Edited 2 times, last by Mike72 ().

  • FullHD-Fernseher. Ist das so entscheidend für das Ambilight? Bildssignal kommt doch vom sky-Receiver über HDMI-Kabel/Splitter/HDMI2AV/Grabber in den USB vom Pi .

    Und es ist definitiv nur Hyperbian auf der SD-Karte.

    Das mit dem y und z hab ich in der Zeile login getestet: sind auf meiner Tastatur vertauscht, geht aber trotzdem nicht.

    Habe mich über PuTTY verbunden und Passwort (ohne y oder z) geändert (endlich mal was geklappt).

    Eigentlich flackern die Farben nur hell bis dunkel in bläulichem Ton. Was muss ich wo einstellen.

  • Kodi sowie Libreelec läuft. Muss ich da irgned ein Addon starten?

    PuTTY verbindung geht.

    Hyperion Konfiguration hat auch Verbindung.

    Einzig die Led's bleiben weiß bzw bläulich. Aber Bei RGB Assistenten leuchten die rot und grün.

    Denke die Einstellungen sind mies.

    Beweisfoto (von IP-Cam da sich mein PC in einem anderen Raum befindet)

  • Kodi sowie Libreelec läuft. Muss ich da irgned ein Addon starten?

    Nein, brauchst kein zusätzliches Addon. Kodi kannst du als Mediaplayer benutzen.

    Hyperion Konfiguration hat auch Verbindung.

    Auf Hyperion.ng kannst du also zugreifen?

    Einzig die Led's bleiben weiß bzw bläulich. Aber Bei RGB Assistenten leuchten die rot und grün.

    LED-Hardware steht auch auf "an"?



    Denke die Einstellungen sind mies.

    Zeig mal deine Einstellungen in Hyperion.

  • Ambilight geht ! Farben sind noch bisschen anpassungsbedürftig.

    Als ich gestern den Fernseher und den Receiver ausgeschalten hatte, habe ich beide Geräte nochmal eingeschaltet ... und siehe da - es ging.

    Blöd ist nur dass ich nicht genau weiß warum es jetzt geht oder woran genau es gelegen hat dass es jetzt funktioniert. Sollte es wieder mal zu einem Ausfall kommen, wäre es schön wenn man die Vorgehensweise rekonstruieren könnte. Habe auch im Kodi rumprobiert (aber als einer der "ahnungslosen" natürlich nicht gewusst ob es was bewirkt).


    Welche Einstellung soll ich genau zeigen? Gibt ja einige davon.

    LED-Hardware streht auf "an".

    Wie gesagt: am Feintuning liegts jetzt. Wie kann ich farbige Testbilder am Fernseher anzeigen lassen damit ich die Farben anpassen kann?

    Bildsignale müssen doch über den Grabber reinkommen, oder? Muss ich die "Bildschirm Aufnahme" aktivieren (Framebuffer, DispmanX)? Das mit dem Farbkalibrierungs-Assistenten bedarf scheinbar auch einer präziseren Beschreibung.

    Edited once, last by Elko1023: Ein Beitrag von Elko1023 mit diesem Beitrag zusammengefügt. ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!