Sk6812 RGBW-NW mit RPi4,RaspBian Buster,Hyperion Alpha6

  • Oder Hyperion 9 runterladen.


    https://github.com/hyperion-pr…-alpha.9-Linux-armv7l.deb
    und in deinem Home Verzeichnis dann per Konsole

    Code
    sudo dpkg -i Hyperion-2.0.0-alpha.9-Linux-armv7l.deb

    ausführen.


    Oder dieser Befehl lädt Hyperion runter.
    https://github.com/hyperion-pr…-alpha.9-Linux-armv7l.deb

    Code
    wget https://github.com/hyperion-project/hyperion.ng/releases/download/2.0.0-alpha.9/Hyperion-2.0.0-alpha.9-Linux-armv7l.deb

    https://github.com/hyperion-pr…-alpha.9-Linux-armv7l.deb
    Da du ja in der Konsole immer im Home Verzeichnis raus kommst nur noch

    Code
    sudo dpkg -i Hyperion-2.0.0-alpha.9-Linux-armv7l.deb

    ausführen und schon hast du installiert.
    Die Anpassungen für SK6812 LEDs findest du ja am Anfang vom Thread.

  • Hallo Cosmicbase, habe jetzt den 2 befehl ausgefürt ssh auch gemacht muss ich noch die Wlan config erstellen ? Komme nicht auf dem Dashbord was mach ich falsch ? Habe auch ein reboot gemacht nach der install. Und was meinst du mit ausführen ? Kenne mich noch nicht so gut damit aus . Gruß Jens

  • @Jens Masla


    Nimm Hyperbian und gut ist. Dir fehlen einfach die Grundkenntnisse, möchte hier jetzt nicht besserwisserisch klingen, aber informiere dich doch einfach mal ein wenig.
    So wie Du Raspbian draufbekommen hast, wirst Du auch Hyperbian draufbekommen.....

  • @Lord-Grey und Ich haben Dir den Link zu Hyperbian gesendet. Es steht was zu machen ist, auch für Neulinge sollte das zu bewältigen sein. Lies Dir das doch mal durch. Wie gesagt, so wie Du Rasbian draufbekommen hast, wirst Du auch Hyperbian draufbekommen, es ist ein angepasstes Image...

  • Ja , aber warum komme ich nicht aufs Dashboard? Ist das weil ich ein reboot gemacht habe? ssh ist auch ok kann mich mit dem Raspi verbinden . Habe von Cosmicbase den 2 Download genommen und installiert. . Kann man über ssh sehen ob das überhaupt installiert ist? ?

  • Wenn du noch den Befehlen also nach der Installation keine Fehler in der Konsole hattest dann sollte im Browser (Deine IP Adresse:8090) der Weg zum Dashboard sein.
    Und nein du brauchst auch keine WLAN Config. Wozu wenn du ja per LAN verbunden bist.


    Der 2. Download ladet ja nur den Hyperion Ordner runter. Mit dem

    Code
    sudo dpkg -i Hyperion-2.0.0-alpha.9-Linux-armv7l.deb

    installierst du es erst.


    Die Installation sollte unter

    Code
    /usr/share/hyperion

    sein. Über die Konsole kommst du mit

    Code
    cd /usr/share

    ins Zielverzeichnis. Und
    mit

    Code
    ls

    musst dann den Hyperion Ordner sehen. Wenn alle Abhängigkeiten und Bibliotheken richtig installiert wurden sollte Hyperion funktionieren.

  • @Cosmicbase:
    Hallo,
    In den ersten Posts hast du die SK6812 ja noch direkt am RPi betrieben, ohne WLED. Für ein neues Projekt würde ich mich auch für diese Lösung interessieren.
    Vor allem welcher Daten-Pin vom Pi wird verwendet?
    Danke!

    Grüße aus Österreich / Greetings from Austria !

    - Don't wanna miss it anymore !

  • login as: pi
    pi@192.168.178.55's password:
    Linux raspberrypi 5.10.11-v7l+ #1399 SMP Thu Jan 28 12:09:48 GMT 2021 armv7l


    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.


    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Wed Feb 17 13:18:54 2021 from 192.168.178.53


    SSH is enabled and the default password for the 'pi' user has not been changed.
    This is a security risk - please login as the 'pi' user and type 'passwd' to set a new password.


    pi@raspberrypi:~ $ cd /usr/share
    pi@raspberrypi:/usr/share $ ls
    accountsservice liblangtag
    aclocal liblouis
    adduser liblouisutdml
    agnostics libnumbertext
    alacarte libreoffice
    alsa librtimulib-utils
    ant libthai
    apparmor-features libwacom
    appdata lightdm
    application-registry lintian
    applications locale
    apport luajit-2.1.0-beta3
    apps lxappearance
    apt-listchanges lxde
    aspell lxinput
    avahi lxpanel
    base-files lxsession
    base-passwd lxterminal
    bash-completion man
    binfmts man-db
    bluej matplotlib
    bug maven-repo
    build-essential menu
    ca-certificates metainfo
    ca-certificates-java mime
    calendar mime-info
    chromium-browser mimelnk
    cmake misc
    code-the-classics mu-editor
    color mysql-common
    colord nano
    common-licenses nfs-common
    consolefonts node-gyp
    console-setup npm
    consoletrans numpy
    cups numpy3
    dbus-1 obconf
    debconf openal
    debhelper openjfx
    debian-reference openssh
    debian-reference-common PackageKit
    debianutils pam
    desktop-base pam-configs
    desktop-directories pcmanfm
    dhcpcd perl
    dh-python perl5
    dict piclone
    dictionaries-common pi-greeter
    dispsetup.sh pi-language-selector
    distro-info pi-package
    djvu pipanel
    doc piwiz
    doc-base pixmaps
    docutils pkgconfig
    dpkg pkg-config-crosswrapper
    drirc.d pkg-config-dpkghook
    emacs plasma
    emacsen-common plymouth
    enchant polkit-1
    ffmpeg poppler
    file ppd
    fio publicsuffix
    firebird3.0-common pulseaudio
    firmware-microbit-micropython pypy
    fkms pyshared
    fontconfig python
    fonts python3
    fonts-droid-fallback python-apt
    galculator python_games
    gcc-8 python-wheels
    GConf qjackctl
    gdb qpdfview
    geany qt5
    GeoIP qt5ct
    gettext raspberrypi-artwork
    ghostscript raspi-config
    git-core raspi-ui-overrides
    gitweb rc-gui
    glib-2.0 readline
    glvnd rp-bookshelf
    gnome rpd-wallpaper
    gnome-background-properties rp-prefapps
    gnome-control-center rubygems-integration
    gnupg ruby-prawn
    gpicview ruby-rouge
    greenfoot scratch
    groff selinux
    gst-plugins-bad sensible-utils
    gst-plugins-base sgml
    gstreamer-1.0 sgml-base
    gtk-engines smartsim
    gtksourceview-3.0 snmp
    gui-pkinst solid
    gutenprint sonic-pi
    gvfs sounds
    hal squeak
    help ssl-cert
    hplip system-config-printer
    hunspell systemd
    hyperion systemtap
    hyphen tabset
    i18n tasksel
    icons tcltk
    images terminfo
    info themes
    initramfs-tools thonny
    iptables thumbnailers
    iso-codes usb_modeswitch
    jackd vim
    java vl805fw
    javascript vlc
    jupyter vnc
    keyrings wallpapers
    keyutils X11
    kramdown xgreeters
    libc-bin xml
    libdrm xml-core
    libexttextcat xsessions
    libfm zenity
    libgphoto2 zoneinfo
    libinput zsh
    pi@raspberrypi:/usr/share $



    hallo kosmicbase , hier eine ausgabe .

  • Hallo Cosmicbase, hier noch eine ausgabe mit einen fehler .


    login as: pi
    pi@192.168.178.55's password:
    Linux raspberrypi 5.10.11-v7l+ #1399 SMP Thu Jan 28 12:09:48 GMT 2021 armv7l


    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.


    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Wed Feb 17 13:21:07 2021 from 192.168.178.53


    SSH is enabled and the default password for the 'pi' user has not been changed.
    This is a security risk - please login as the 'pi' user and type 'passwd' to set a new password.


    pi@raspberrypi:~ $ sudo dpkg -i Hyperion-2.0.0-alpha.9-Linux-armv7l.deb
    (Lese Datenbank ... 165356 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von Hyperion-2.0.0-alpha.9-Linux-armv7l.deb ...
    ---Hyperion ambient light preinst ---
    Entpacken von hyperion (2.0.0) über (2.0.0) ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von hyperion:
    hyperion hängt ab von libcec4; aber:
    Paket libcec4 ist nicht installiert.


    dpkg: Fehler beim Bearbeiten des Paketes hyperion (--install):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    Fehler traten auf beim Bearbeiten von:
    hyperion
    pi@raspberrypi:~ $

  • Code
    sudo apt install libcec4
    sudo dpkg -i Hyperion-2.0.0-alpha.9-Linux-armv7l.deb


    Lesen was du postest, da steht fast immer der Fehler.


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    Hyperion (classic) & Plugin HyperionControl (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon



    Ambilight for ever

  • Steht doch alles im Code:


    gruß pclin

    Dreambox ONE / TWO
    Amlogic S922X - 53.000 DMIPS - 2 GB RAM - 16 GB Flash - Twin-DVB-S2X Tuner - HDR10 - HLG
    -
    AudioDSP: miniDSP 2x4HD - Lautsprecher ELAC
    LG 65' SUHD
    -
    Hyperion (classic) & Plugin HyperionControl (dreamOS)
    Hyperion-ng (Debian Buster)
    -
    6 x Wemos D1 mini - WLED - SK6812 RGBW-NW 60 LEDs/m
    5-Port HDMI Switch - FeinTech VSP01201 - Grabber Macrosilicon



    Ambilight for ever

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!