Die Grenzen eines analogen Grabbers - und die digitale Lösung

  • Sorry, muss aber leider dumm fragen. Wo macht man das


    Also wenn ich den Befehl "sudo hyperion-v4l2" eingebe, startet der externe grabber und ich sehe im Live Bild der WebUI das Bild von meiner VU. Schließe ich putty, ist alles wieder schwarz

  • Das kannst du bequem über das WebUI von Hyperion machen. Ich bin gerade nicht bei meinem Setup aber irgendwo kannst du die Optionen für die Quellen setzen. Dort musst du im Bereich externe Quelle diese Optionen setzen. Außerdem musst du, auf der selben Seite und sofern du nur den externen Grabber verwenden willst, den internen Platformgrabber deaktivieren und USB Grabber aktivieren.


    Falls du es nicht findest macht sicherlich jemand Screenshots.

  • Hi,


    wenn du unbedingt die Console nehmen willst oder das Ganze per Script schalten, ist hyperion-remote der bessere Weg.


    Code
    hyperion-remote -E V4L
    hyperion-remote -D V4L


    Putty landet danach wieder auf der Komandozeile und kann geschlossen werden.


    Grüße


    Micha

  • Ich kann dir nichtmal sagen, ob der Inputlag bei meinem Grabber gering oder hoch ist. Für mich war der Beweggrund gleich 4K-Ready zu sein, da mein TV mittlerweile fast 10 Jahre auf dem Buckel hat und man da nie weiß, wann eine Neuanschaffung ansteht. Außerdem benutze ich die eingebaute Splitter-Funktion des Grabbers, zumindest unter FullHD, ohne Probleme.


    In Summe macht das, für mein Empfinden, dann ein zwar sehr teures aber gerade noch vertretbares Paket.

  • Warum werden eigentlich diese teuren Grabber benutzt?


    Hi,


    bei dem Grabber handelt es sich nicht um einen digitalen im im eigentlichen Sinne. Die Chinesen haben einfach den HDMI Converter und analog Grabber in ein Gehäuse gepackt. Im Ergebniss also ein bescheidenens Bild mit allen Nachteilen einer verrauschten 720x576p Aufnahme. Hatte den auch mal getestet und dann entsorgt, da er bei 1080/50p nur die linke Seite, also nur 50% vom Bild aufgenommen hat.
    Ich bin mit folgendem recht zufrieden, damals für 39€ erworben, als er noch lieferbar war. Preislich der unterste Einstieg, wenns digital sein soll.


    https://www.amazon.de/gp/produ…tle_o00_s00?ie=UTF8&psc=1


    https://de.aliexpress.com/item….productlist.0.0.27051971


    Grüße


    Micha

  • Welchen Grabber könnt ihr empfehlen um Dolby Vision und HDR 10+ verarbeiten zu können. Die Analoge Variante scheitert, ich kann zwar das Signal von 4k auf 1080p konvertieren, aber HDR bzw. Dolby Vision ist weiterhin in dem Signal enthalten und keiner meiner HDMI2AV Konverter kann damit umgehen. Bzw. die Ausgabe des Analog Signals ist nicht nutzbar für Hyperion.
    Links 4k SDR - Rechts 4k DolbyVision oder 4k HDR

  • Hallo zusammen,


    Ich habe den Thread komplett gelesen und bin ein bisschen verwirrt. Ich habe vor 4 Jahren 2 Ambilight Systeme aufgebaut mit analogen Grabber ich habe weder bei Standbild noch bei schwarzen Bilder ein Flackern. Ich habe damals viel eingestellt und mit der Threshold gearbeitet was das Flackern komplett auf beiden Systemen unterbunden hat.


    Beide Stripes waren sehr unterschiedlich bei dem zweiten musste ich blau anteil auf 25% Schrauben um annähernd ein weiß zu erhalten... jedenfalls habe ich nach langen Probieren auf beiden ein Top Ergebnis erzielt Grau war problematisch und braun. Aber auch das konnte ich völlig zufriedenstellend lösen und es haben wirklich alle Farben gepasst zu 95%.


    Warum haben hier so viele Probleme mit dem Flackern?
    Ich bin gerade am Sachen zusammen suchen um ein 4k Ambilight zu bauen... das Flackern macht mich ein wenig stutzig hier.


    Ich habe damals bestimmt 4 Stunden mit Filmen und kalibrier Bilder gebraucht um ein Gutes Bild zu bekommen. Der eine Stripe hat ein perfektes Weiß geliefert und läuft bis heute und ist eine Wahre Wonne.


    Bei schwarzen Bildinhalten sind die Leds aus und bleiben es auch... ich habe gelesen, dass Hyperion NG kein Threshold mehr besitzt... und ganz am.anfang dieses Threads hat ebenfalls einer erwähnt das es damals damit in den griff zu bekommen war. Stripes waren damals ws2801 habe jetzt apa102 aus China bestellt


    Grüße an alle Bastlerkollegen


    Daniel



    Ps: zu erwähnen wäre noch das der TV nicht direkt an der Wand steht sodass ein etwaiges leichtes leuchten (wenn es schwach ist) nicht direkt auffallen würde.

  • Also meiner Meinung nach hat die breite Verfügbarkeit der digitalen Grabber bzw. der All-in-One Grabber, die ggf. intern doch analog arbeiten, die Qualität soweit verbessert bzw. das Rauschen vermindert, dass das Blurring nicht mehr notwendig ist.


    Wie gesagt, ich hatte das Blurring auf vergleichsweise starker Hardware getestet und es hat gut funktioniert. Wer jedoch Geld ausgeben möchte oder kann wird sicherlich nicht mehr mit den früher beliebten Grabbern arbeiten wollen. Wer kein Geld ausgeben möchte wird wahrscheinlich keine starke Hardware sondern eher einen Pi3 o.Ä. verwenden wollen.


    Viele Grüße


  • Hi,


    ich habe mir auch diesem Grabber geholt und bin vom Bild total begeistert!


    Nur kommt es ab und zu vor, das sich bei mir die Helligkeit verstellt. Leds werden total dunkel und die Eingabe "v4l2-ctl --list-ctrls" bringt mir einen Wert für brightness von 0!


    wenn ich den Wert dann per "v4l2-ctl --set-ctrl brightness=128" steuere bleibt es ein paar Minuten so und dann wird es wieder dunkel!


    Das geliche Problem habe ich aber auch mit meinem alten Grabber. Habe schon versucht den USB Port zu wechseln, ein frisches Image auf den PI 3b+ (Hyperbian) habe ich auch schon versucht, leider ohne Erfolg. Steuere jetzt als Notlösung meine gewünschten Wert alle 5 Sek von iobroker aus.

  • Hi,


    wenn ich Hyperbian lese, vermute ich, du nutzt das klassiche Hyperion. (boah, miese falsche infos) Dies habe ich mit dem neuen Grabber nie probiert. HyperionNg läuft bei mir noch in einer älteren 2.0.0-alpha.6 Version auf einen Raspbian Buster 10. Den Grabber habe ich am 4er Raspi an einem USB3 Port hängen, an einem 2er USB Port sind mir auch allerdings auch keine Probleme mehr in Erinnerung.
    Bezüglich deines Fehlers mit v4l2-ctl vermute ich, dass dies unabhängig von der Hyperion Version sein sollte. Ich würde also ein Problem in Zusammenhang mit dem USB Port vermuten.Gab es da beim Raspi nicht einen Eintrag in der config.txt, welche den maximalen Strom für den USB Port regelt? Vielleicht auch einfach mal einen aktiven USB Hub zwischenhängen.


    Grüße
    Micha

  • Hi,


    wenn ich Hyperbian lese, vermute ich, du nutzt das klassiche Hyperion. (boah, miese falsche infos) Dies habe ich mit dem neuen Grabber nie probiert. HyperionNg läuft bei mir noch in einer älteren 2.0.0-alpha.6 Version auf einen Raspbian Buster 10. Den Grabber habe ich am 4er Raspi an einem USB3 Port hängen, an einem 2er USB Port sind mir auch allerdings auch keine Probleme mehr in Erinnerung.
    Bezüglich deines Fehlers mit v4l2-ctl vermute ich, dass dies unabhängig von der Hyperion Version sein sollte. Ich würde also ein Problem in Zusammenhang mit dem USB Port vermuten.Gab es da beim Raspi nicht einen Eintrag in der config.txt, welche den maximalen Strom für den USB Port regelt? Vielleicht auch einfach mal einen aktiven USB Hub zwischenhängen.


    Grüße
    Micha


    Yes. Standardmässig lässt der Pi nur 600 mA an allen USB ports gleichzeitig zu, war zumindest früher so...für manche Grabber reicht das nicht und man kann über die config:


    sudo nano /boot/config.txt


    und dort dem extra eintrag:


    max_usb_current=1


    STRG + X und anschließender neustart und schon stehen 1.2A zur Verfügung...


    Grüße

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!